Saving CoffeeScript does nothing

May 13, 2011 at 8:15 AM


I am probably missing something, but when I save the .coffee file it doesn't get compiled and nothing happens.

Steps I've done:

  1. Install the plug-in.
  2. Download the Windows compiler and put it under C:\Tools\coffeescript-compiler
  3. In VS 2010 went to Tools>Options>Chirpy>CoffeeScript and set the compiler to C:\Tools\coffeescript-compiler\coffee.bat
  4. Added a new file to existing MVC3 project: public\js\ with the following content: "1+1"
  5. Saved it.
  6. Nothing happened :(

I played a bit with different options but I don't even get any Console output from Chirpy.

Could you please suggest what I might be missing?


Jun 11, 2011 at 12:45 AM

All your steps look good, except the default extension Chirpy looks for is *

Change your file to and you should be in business!


Jul 21, 2011 at 6:40 PM

I have same problem here, the only one diference is that I'm using coffee.exe on compiler.

If I open file.js and change and save, VS ask me to reload it, but it have no content.

What should I do?

Aug 10, 2011 at 6:54 PM

"" change to "" or change file extension in configuration screen.

Aug 21, 2011 at 4:27 PM

For some reason, I'am having problem to switch from the default (dll build-in) CoffeeScript compiler to custom one. Even filled an issue on this:

The source code for the default compiler is in Chirpy dll and I can not fine the source code for the library to recompile.