No files are being generated

Sep 30, 2010 at 1:58 PM


Just downloaded and installed the latest version of Chirpy. I can see in the VS2010 addin manager that the addin has been loaded. When I create (for example)

foo.yui.js or bar.chirp.less I can see in the output windows that LessEngine and YuiJsEngine are being invoked for the files - however no files are being outputted

by the addin.

They are not displaying in the solution explorer nor are they actually available in the folder on the drive either. There are no errors being reported.

Any ideas on how I can resolve this?



Oct 1, 2010 at 3:30 AM

More detail

Windows version.

VS2010 version .

Project type

Oct 1, 2010 at 5:49 AM
Edited Oct 1, 2010 at 6:07 AM

Windows 7 x64
Visual Studio 2010 Professional
ASP.NET MVC2 Project
Latest version (from codeplex) of Chripy 


I've now tried it on two different machiens with the same setup and the same results - I see that the engines are being invoked but there are no

files being generated for me. 


EDIT: Just tried it with an ASP.NET project as well - same results

Oct 2, 2010 at 12:22 AM

Send your solution.

The console version work on your file ?

Oct 2, 2010 at 8:16 AM

There's nothing to be seen in the solution.. I created a brand new ASP.NET MVC (and later ASP.NET Website) project just to try it out

How do I run the console version?

Also I have not downloaded any of the minimizers etc as separate tools, I assume they are baked into Chirpy?

Oct 2, 2010 at 1:59 PM

All minimizers is merge in Chirpy dll.


Console version information :

Watch changeset : b1b7a2d4cca9

Add chirpy command-line
Only support engine : YuiCssEngine,YuiJsEngine,ClosureCompilerEngine,LessEngine,MsJsEngine,MsCssEngine
Simply call program with folder path in argument.
Sample : Chirpy.exe c:\testsite\

Oct 5, 2010 at 8:35 AM


So I just ran the console version and there were some issues with running it out of the box. I called the exe as following

chirpy.exe "pathToProject" and the project I was testing it on had one foo.yui.js and one bar.chirp.less file


(1) Following line threw an NullReferenceException

extensions = extensions == null ? Settings.AllExtensions : extensions.Union(Settings.AllExtensions).ToArray();

In the Utilities.GetBaseFileName method. The reason for it is that Settings.AllExtensions is null. However, if I commented

out the line then it was able to build a foo.min.js file as expected!


(2) When it got to the bar.chirp.less file there was another problem. The TransformToCss method in the LessEngine.cs file

throw another NullReferenceException, this time for the following line

TaskList.Instance.Add(projectItem.ContainingProject, Microsoft.VisualStudio.Shell.TaskErrorCategory.Error, fullFileName, line, column, description);

The reason being that TaskList.Instance is null.


All in all it doesnt appear that Chirpy is quite ready for a console runner since there seem to be a couple of dependencies for the IDE

still. However, I'm not quite sure why either engines work when they are invoked from inside of Visual Studio by the add-in, even though that I can see

in the output window that they have executed. I really hope you can help me resolve this since the capabilities it adds to a web developer is



Thanks you, looking forward to resolving this issue soon

Oct 5, 2010 at 2:14 PM

I'm seeing the same issue. I'm using and it does not seem to work with regular ASP.NET MVC 2 project.

It does not generate files but the output windows indicates some kind of activity:  ClosureCompilerEngine -- c:\Temp\MvcApplication3\MvcApplication3\Scripts\jquery-1.4.1-vsdoc.chirp.js

My Setup:

  • Windows 7 x64
  • VS 2010 Premium

Anything I can do to help you with the issue ? Is there a log I can look at ?

Oct 5, 2010 at 11:45 PM

I believe this issue is specific to 64 bit OS that we are both running. I've fixed it and you can grab the diff file from here:




Oct 6, 2010 at 12:05 AM
Edited Oct 6, 2010 at 12:39 AM


Console application work on my test PC (windows 7 32bit)

New version of code source available show message box when error throw on load setting in registry and fix for x64.

Oct 12, 2010 at 2:07 AM

I've got Win7 x64 and I just downloaded the latest source code.

The Console application works for me, but no entirely as I expected.

When I run it, it just transforms the .less files (I don't have any other), but it does nothing with the .config file.

Is there a way to make it make groups as defined in the .config file?

I have the same problem as described here:, and I though I could temporarily bypass it with a pre-compile events, as I really need the files for groups only when I build (no IntelliSense in Razor views yet).




Oct 12, 2010 at 11:01 PM
Edited Oct 16, 2010 at 11:39 PM

Presently console application don't support .config file.

UPDATE: Changeset 0a122aa3007d support .config file.

Oct 18, 2010 at 7:27 AM


I just tried the version you posted on the 6th of October ( and it works fine when I run it in the Console

runner, but if I build the solution and copy the Chirpy.dll and Zippy.AddIn files to my VS2010 Addins folder I get the same results as before - I can see in the output windows that it

is being invoked but there are no files being generated and included in my project. In fact I did a search for the files on my entire harddrive and they are noway to be found, it's not

a rouge path thats the problem, there is no file, at all, being generated.


This is killing me! Really want to use this awesome tool! :-)

Oct 19, 2010 at 11:50 PM

Test new code source.

This new code content :

- try-catch when action run.

Oct 20, 2010 at 7:03 AM

I have no idea why, but this version works and I don't get the messagebox/output window trace that you added. Odd, but awesome at the same time!