Upgrading dotLess

Oct 27, 2011 at 2:49 PM
Edited Oct 27, 2011 at 2:51 PM

Hi All,

I wanted to upgrade the DotLess.core hoping to fix below issue, but it doesn't seem to work. The reason I want to upgrade is that below issue, eventhough it is 'escaped', still throws an error:

..\Safarinow.Web\res/css/Generic.less(7448,5)Expected '}' on line 7448 in file '..\Safarinow.Web\res/css/Generic.less':
[7447]:     background: -ms-linear-gradient(top, white 0%,#F0F0F0 100%);
[7448]:     filter: ~"progid:DXImageTransform.Microsoft.gradient( startColorstr='#ffffff', endColorstr='#f0f0f0',GradientType=0 )";
[7449]:     background: linear-gradient(top, white 0%,#F0F0F0 100%);

Chirpy currently contains DotLess version, but DotLess is currently at I tried replacing the dotless.Core.dll and dotless.Core.pdb files, but that results in following error:

Unhandled Exception: System.IO.FileLoadException: Could not load file or assembly 'dotless.Core, Version=, Culture=neutral, PublicKeyToken=96b446c9e63eae34' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
   at Zippy.Chirp.Engines.LessEngine.TransformToCss(String fullFileName, String text, ProjectItem projectItem)
   at Zippy.Chirp.Engines.ConfigEngine.Run(String fullFileName, ProjectItem projectItem) in C:\Users\enagle\Desktop\Chirpy 3211\Engines\ConfigEngine.cs:line 130
   at Console.Chirp.Program.Main(String[] args) in C:\Users\enagle\Desktop\Chirpy 3211\Console.Chirp\Program.cs:line 50


How do I fix this issue?



Nov 1, 2011 at 9:35 PM

Download last source code.

Dotless is change to in changeset : 6a8c1be48669

Nov 3, 2011 at 4:10 PM

I downloaded the latest source code, 2075b4f94ae6, opened the zip file and ran  \bin\Chirpy.vsi. 

This did not solve this problem. Did I do something wrong or is this an issue with VS?

Nov 4, 2011 at 11:17 PM

Download last version and build on your pc.