Less not being compiled

Oct 7, 2011 at 2:24 PM
Edited Oct 7, 2011 at 2:27 PM

Hi Guys,

Thanks for this great product!

I'm am having some issues using .less...  .css and .js files work perfectly, but .less files don't. Chirpy does create the expected files, but they remain empty. So it seems there is something wrong with the dotless parser?

I have just downloaded Maragogype Chirpy v2.01, which is the latest version I think.

Any idea what could be the issue here?

 

Thanks in advance!

Richard

p.s. using VS 2010

Oct 7, 2011 at 3:03 PM

Sorry for my ignorance.

There was an error (according to the dotless compiler) in the syntax of the .less file. I think this is an error in the dotless compiler, because it worked using the less.js file to compile on the fly and it was also done according to the lesscss documentation.

It involves this line: 

 ~"filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='@from', endColorstr='@to',GradientType=0 );"

As you can see, the line is escape properly, but it wouldn't compile non the less..
Nov 3, 2011 at 4:03 PM

Did you ever solve this problem? I'm having the exact same issue. The error I receive is as follows:

Expected '}' on line 121 in file 'style.yui.less':
[120]:     text-decoration: none;
[121]:     filter: dropshadow(color=#999999, offx=3, offy=3);
       ----^
[122]:     text-shadow: 3px 3px 15px #999999;

I set my VS options to recognize .yui.less. When I include that 'filter' line, the min file is empty. 

Nov 4, 2011 at 7:00 AM

Try

 

  

filter: formatstring("dropshadow(color=#999999, offx=3, offy=3)");

Nov 9, 2011 at 6:09 PM
richyk wrote:

Try  

filter: formatstring("dropshadow(color=#999999, offx=3, offy=3)");

 

That worked! Thanks.