Getting error when starting VS 2010

Oct 8, 2010 at 3:53 PM

I am using VS 2010 on Win 7 x64.  I am getting this error when starting with Chirpy.

The Add-in 'Chirpy' failed to load or caused an exception. Would you like to remove this Add-in? If you choose yes, the file it was loaded from...will be renamed.  Error Message: <Unknown Error>  Error Number: 80131515

Thanks,

Vincent

Developer
Oct 10, 2010 at 8:35 PM

Chirpy version ?

Oct 10, 2010 at 10:20 PM

The ver 1.0.0.5. I also download the most recent project and built it.  Still doesn't work.

Developer
Oct 11, 2010 at 3:00 PM

Console version work ?

Oct 11, 2010 at 3:34 PM

I have exactly the same problem. The command llive version works perfectly but any attempt to install the add-in throws an unknown error on load.

Just like Vincent I am using VS 2010 on Win 7 x64.

I have tried building from source with the latest set (545c2664560a) and it's still the same problem. Also tried the packaged releases v1.0.0.5.3, v1.0.0.5.2, and a couple of earlier ones too just for good measure but so far no success.

In fact I tried debugging the add-in but the error seems to occur before I can even get to the point of debugging. I started to wonder if I was missing some sort of dependency but I have the Visual Studio SDK, Java runtime and SDK, and everything else I could find that looks like it might even be a remote dependency. I am starting to think it's related to the way WOW64 has a seperate set of registry keys and if nobody has a solution soon I will go digging in that direction because this is exactly the tool I want my team to use - assuming we can make it work of course.

Cheers,

Philippe

 

Developer
Oct 11, 2010 at 5:33 PM

Chirpy install on network drive ?

http://chirpy.codeplex.com/workitem/28

"

The solution of adding the following switch to the devenv.exe.config file in the blog post linked to by "weirdlover" worked for me.

<configuration>
<runtime>
<loadFromRemoteSources enabled="true"/>
</runtime>
</configuration>

"

Oct 11, 2010 at 5:47 PM

Yep. I keep a lot of my user folders on a network device, and it turns out that Visual Studio sees the standard path for Add-Ins as being a remote location.

Which actually explains perfectly the issue and enabling loadFromRemoteSources fixes the problem instantly. My latest project is now happily chirping away.

Thanks - the quick reply on that is greatly appreciated.

Philippe

Oct 12, 2010 at 1:11 PM

Worked for me too.  Thanks.